Compatibility with MpongoDB 4.2?

We are installing a new server and were wondering if we can use MongoDB 4.2 (released recently) as in system requirements you recommend MongoDB 3.6 ?