Flatmap-stream package

Hi,

We are currently running 18.08.1 Enterprise Edition of Countly which unfortunately contains a vulnerable version of the flatmap-stream package.

Could you advise if there is an updated version of Countly that does not include this vulnerable version or if there is a way we can remove this from 18.08.1?

Thank you.

Cheers,

Kent

Hello,
yes, of course, the latest one is 19.02.1

if you need Enterprise version, contact support at count.ly and one will be provided/added to your folder :slight_smile:

Arturs,

So this means we need to move up from 18.08.x to the 19.02.x release to get the fix.

From the release logs, it appears there was quite a significant amount of changes made in the 19.02.x builds.

We are using countly-sdk-js to connect to Countly Server and which from what I can see the latest version is 18.08.3, there doesn't to be a 19.x version available. Will the 18.08.3 sdk work against the 19.02.01 Countly Server?

Thank you.

Cheers,

Kent

Hello,
yes SDK communication protocol does not change almost at all. All the changes are on the serverside, mostly adding new functionalities. But new server always will be backwards compatible with older SDKs

Arturs,

Appreciate the clarification. I will ask the team to get in touch with support to arrange accordingly.

Thank you.

Cheers,

Kent