Unable to install countly server in RED hat linux 7


#1

Dear All,

I have downloaded countly v19.02.1 from https://github.com/Countly/countly-server/releases and tried to install as per documentation like

sudo su - 
cd COUNTLY_INSTALLATION_DIRECTORY/bin
bash countly.install.sh

Note : SELinux is disabled in this server
But I am getting below error

[root@countlyhost bin]# ./countly.install.sh

______ __ __

/ ____/___ __ ______ / /_/ /_ __

 / / / __ \/ / / / __ \/ __/ / / / /

/ /___/ /_/ / /_/ / / / / /_/ / /_/ /

\____/\____/\__,_/_/ /_/\__/_/\__, /

http://count.ly/____/

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

Package wget-1.14-18.el7.x86_64 already installed and latest version

Package 1:openssl-devel-1.0.2k-16.el7.x86_64 already installed and latest version

Package gcc-c++-4.8.5-36.el7.x86_64 already installed and latest version

Package 1:make-3.82-23.el7.x86_64 already installed and latest version

Package git-1.8.3.1-20.el7.x86_64 already installed and latest version

Package sqlite-3.7.17-8.el7.x86_64 already installed and latest version

Package unzip-6.0-19.el7.x86_64 already installed and latest version

Package bzip2-1.0.6-13.el7.x86_64 already installed and latest version

Nothing to do

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

Package pango-1.42.4-1.el7.x86_64 already installed and latest version

Package libXcomposite-0.4.4-4.1.el7.x86_64 already installed and latest version

Package libXcursor-1.1.15-1.el7.x86_64 already installed and latest version

Package libXdamage-1.1.4-4.1.el7.x86_64 already installed and latest version

Package libXext-1.3.3-3.el7.x86_64 already installed and latest version

Package libXi-1.7.9-1.el7.x86_64 already installed and latest version

Package libXtst-1.2.3-1.el7.x86_64 already installed and latest version

Package 1:cups-libs-1.6.3-35.el7.x86_64 already installed and latest version

Package libXScrnSaver-1.2.2-6.1.el7.x86_64 already installed and latest version

Package libXrandr-1.5.1-2.el7.x86_64 already installed and latest version

Package GConf2-3.2.6-8.el7.x86_64 already installed and latest version

Package alsa-lib-1.1.6-2.el7.x86_64 already installed and latest version

Package atk-2.28.1-1.el7.x86_64 already installed and latest version

Package gtk3-3.22.30-3.el7.x86_64 already installed and latest version

Package ipa-gothic-fonts-003.03-5.el7.noarch already installed and latest version

Package xorg-x11-fonts-100dpi-7.5-9.el7.noarch already installed and latest version

Package xorg-x11-fonts-75dpi-7.5-9.el7.noarch already installed and latest version

Package xorg-x11-utils-7.5-23.el7.x86_64 already installed and latest version

Package xorg-x11-fonts-cyrillic-7.5-9.el7.noarch already installed and latest version

Package xorg-x11-fonts-Type1-7.5-9.el7.noarch already installed and latest version

Package xorg-x11-fonts-misc-7.5-9.el7.noarch already installed and latest version

Nothing to do

## Installing the NodeSource Node.js 8.x LTS Carbon repo...

## Inspecting system...

+ rpm -q --whatprovides redhat-release || rpm -q --whatprovides centos-release || rpm -q --whatprovides cloudlinux-release || rpm -q --whatprovides sl-release

+ uname -m

## Confirming "el7-x86_64" is supported...

+ curl -sLf -o /dev/null 'https://rpm.nodesource.com/pub_8.x/el/7/x86_64/nodesource-release-el7-1.noarch.rpm'

## Downloading release setup RPM...

+ mktemp

+ curl -sL -o '/tmp/tmp.yu5nSVxocV' 'https://rpm.nodesource.com/pub_8.x/el/7/x86_64/nodesource-release-el7-1.noarch.rpm'

## Installing release setup RPM...

+ rpm -i --nosignature --force '/tmp/tmp.yu5nSVxocV'

## Cleaning up...

+ rm -f '/tmp/tmp.yu5nSVxocV'

## Checking for existing installations...

+ rpm -qa 'node|npm' | grep -v nodesource

## Run `sudo yum install -y nodejs` to install Node.js 8.x LTS Carbon and npm.

## You may also need development tools to build native addons:

sudo yum install gcc-c++ make

## To install the Yarn package manager, run:

curl -sL https://dl.yarnpkg.com/rpm/yarn.repo | sudo tee /etc/yum.repos.d/yarn.repo

sudo yum install yarn

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

Package 2:nodejs-8.15.1-1nodesource.x86_64 already installed and latest version

Nothing to do

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

Package policycoreutils-python-2.5-29.el7_6.1.x86_64 already installed and latest version

Nothing to do

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

Package 1:nginx-1.14.2-1.el7_4.ngx.x86_64 already installed and latest version

Nothing to do

useradd: user 'www-data' already exists

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

Package python-setuptools-0.9.8-7.el7.noarch already installed and latest version

Nothing to do

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos

There was an error communicating with RHN.

Red Hat Satellite or RHN Classic support will be disabled.

Error communicating with server. The message was:

Not Found

No package epel-release available.

Error: Nothing to do

[root@countlyhost bin]#

Kindly help me how to overcome this issue . I am not getting why this issue is coming.


#2

Hello
just tried to install on latest RHEL 7
there was no problem and installation completed.
Maybe it was some temporary repository networking problems?


#3

There are problems with connecting to RHN, that may be the issue @s.dalabehera


#4

Thanks for your quick response . Right it was network connection issue.

In our organisation we are using internet via proxy that was the reason for issue