Unable to upgrade

Hello,

I'm running countly community edition v18.08 and I'm unable to upgrade it because the upgrade process always hangs on installing dependencies... It seems that NPM hangs when download packages. I've tried almost all solutions to this issues (NPM hang) but without success.

Have you any advice to this?

Thank you,
regards

Hello
usually it is some networking issue either on npm side or your server side.

have you tried running

npm install --verbose

inside countly directory and checking where exactly it hangs?

Hi, thank you for replying me.

npm install --verbose runs fine and tells me that there are 44 module to upgrade.
npm update --verbose hangs here:

....
npm http fetch GET 200 registry.npmjs.org/nyc 168ms
[..................] / rollbackFailedOptional: http fetch GET 200 http://registry.npmjs.org/nyc 168ms

I've tried to download that module with wget and works fine. I've tried to clean NPM cache and some other advices found in internet, but nothing seem work.

Thank you

My only other guess would be stuck file due to possibly permissions?

You can try move/rename current node_modules folder and try installing npm dependencies from scratch
Or try running npm update with sudo and unsafer permissions

sudo npm update --unsafe-perm